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Introduction 

This tutorial details how to set up and instantiate a Nios II system on Terasic Technologies, Inc.’s DE2 
Altera Development and Education Board.  The system includes an interface to the board’s 4MB flash 
memory chip and runs the application program from flash.  It also sets up and implements the LCD, 
seven-segment displays, red and green LEDs, switches, and pushbuttons. 

Background 

Nios II is a 32-bit RISC CPU designed for implementation as a soft core in Altera FPGAs.  Altera’s 
System-on-a-Programmable-Chip (SOPC) Builder allows users to design Nios II systems easily by 
selecting Nios II processors, setting up the associated memory, and adding any desired standard and/or 
custom peripherals.  Once generated, the system is incorporated into an FPGA design with Altera’s 
Quartus II software and instantiated on the FPGA. 
 
Altera provides the Nios II Integrated Development Environment (IDE) for application software 
development.  This tutorial includes instructions for programming an example C application into flash 
and running it on the Nios II. 

Application 

These programs are case sensitive.  If a component is named or renamed, it needs to match what is written 
in this tutorial exactly, or it may not work. 

DE2 Setup 
This tutorial assumes that the user is familiar with the DE2 board and already has the USB-Blaster device 
installed.  Refer to the Getting Started with Altera’s DE2 Board tutorial for more information on 
installing the USB-Blaster driver. 

Starting a New Project in Quartus II 
Open the Quartus II software and create a new project by selecting File > New Project Wizard.  Create a 
folder on the C:\ drive called Tutorial_Files, and create another folder inside of that one called 
Flash_Memory.  Specify the Flash_Memory folder as the working directory for this project.  Also, in 
the second textbox, call the project name Flash_Memory.  The top level entity automatically fills in.  See 
Figure 1. 
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Figure 1.  New Project Wizard 

Make sure the new folders were created directly on the C:\ drive and that there are no spaces in the folder 
names.  Folders created in the My Documents folder cause errors.  For instance, C:\Documents and 
Settings\Firstname_Lastname\My Documents causes an error, because there are spaces in the directory 
path. 
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Click the Next button, and click Next again on page 2.  On the third page, select the EP2C35F672C6 
chip as the target device, which can be seen in Figure 2.  This is the FPGA on the DE2 board.  Click Next 
on the remaining two screens and click Finish. 

 
Figure 2.  FPGA Chip Selection 

Create a new block diagram by selecting File > New, and select Block Diagram/Schematic File.  Save 
this file by selecting File > Save As (not to be confused with Save Project), call it Flash_Memory, and 
click Save.  Naming it Flash_Memory ensures that this block diagram file is the top-most entity of the 
project, as specified in Figure 1. 
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Nios II System Design in SOPC Builder 
The next step is to build a Nios II processor system.  Select Tools > SOPC Builder to open the SOPC 
Builder application.  Set the System Name to NiosII_Processor.  Select either Verilog or VHDL as the 
Target HDL,  and select OK.  It is not necessary to know VHDL or Verilog to continue.  See Figure 3. 

  
Figure 3.  Create New Nios II System 

Error and warning messages appear and disappear sporadically in the information box on the bottom of 
the screen while performing the following steps.  Ignore these errors; they disappear upon successful 
completion of the Nios II system. 
 
In the Clock Settings pane, double click clk_0 and rename it CLOCK_50.  Press Enter. 

Add On-Chip Memory 
On the upper left side of the SOPC Builder window, under Component Library,  expand the Memories 
and Memory Controllers column, then expand On-Chip, and select On-Chip Memory (RAM or 
ROM).  Click the Add button, and a MegaWizard appears.  Set Block Type to M4K,  set Total Memory 
Size to 20, and select Kbytes.  Do not change any other default settings.  Click Finish.  Refer to Figure 4. 
 
Errors may occur after adding the On-chip memory.  Ignore these errors, since they are corrected as more 
components are added to the system. 
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Figure 4.  On-Chip Memory Setup 
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Add a Nios II Processor 
Now, add the Nios II processor to the system.  In the upper left corner of the SOPC window, under 
Component Library , select Nios II Processor, and click the Add button. 
 
In the middle of the MegaWizard window, select Nios II/s as a Nios II core.  Set Hardware Multiply  to 
None.  Do not change any other default value.  Click Finish, and the Nios II processor is added to the 
system.  See Figure 5. 

 
Figure 5.  Nios II Processor Setup 
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Add a JTAG UART 
In order to communicate to the Nios II processor through the USB-Blaster, add a JTAG UART to the 
system.  In the upper left corner of the SOPC window, under Component Library , expand Interface 
Protocols, expand Serial, select JTAG UART,  and click Add.  Do not change any of the default 
settings.  Click Finish.  Refer to Figure 6. 

 
Figure 6.  JTAG UART Setup 
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Add an LCD 
To add the LCD, expand Peripherals, then expand Display, select Character LCD, and click Add.  
There are no settings to modify, so select Finish.  Refer to Figure 7. 
 
Rename the lcd_0 that was generated to ensure proper functionality.  Select lcd_0, right-click on it, select 
Rename, rename it to lcd, and press Enter. 

 
Figure 7.  LCD Controller Setup 
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Add Parallel I/O (PIO) 
Add the switches to the system.  Expand Peripherals, then expand Microcontroller Peripherals , select 
PIO (Parallel I/O) , and click Add.  When the window opens, set the Width  to 18, set the Direction to 
input ports only, and click Finish.  Refer to Figure 8. 
 
Rename the pio_0 that was generated to ensure proper functionality.  Select pio_0, right-click on it, select 
Rename, rename it to switch, and press Enter. 

 
Figure 8.  PIO Switch Setup 
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Add the pushbuttons next.  Similar to the switches, expand Peripherals, expand Microcontroller 
Peripherals, select PIO (Parallel I/O), and click Add.  When the window opens, set the Width  to 4 and 
set the Direction to input ports only.  Go to the Input Options tab, check the synchronously capture 
box, and select Falling edge.  Also, underneath in the Interrupt  section, check Generate IRQ, select 
Edge, and then click Finish.  Refer to Figures 9 and 10. 
 
Rename the pio_0 that was generated to ensure proper functionality.  Select pio_0, right-click on it, select 
Rename, rename it to pb, and press Enter. 

 
Figure 9.  PIO Pushbutton Setup 
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Figure 10.  PIO Pushbutton Interrupt Setup 



Setting Up a Nios II System with Flash Memory on the DE2 
 

Digi-Key Corporation  Page 12 of 30 

The green LEDs are added next.  Expand Peripherals, expand Microcontroller Peripherals , select PIO 
(Parallel I/O), and click Add.  Do not change any of the default settings.  The interface is set up for an 8-
bit output-only PIO, which is needed to use the green LEDs.  Click Finish.  Refer to Figure 11. 
 
To ensure proper functionality, rename the pio_0 that was generated.  Select pio_0, right-click on it, 
select Rename, rename it to ledg, and press Enter. 

 
Figure 11.  PIO Green LED Setup 
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Add the red LEDs next.  Expand Peripherals, expand Microcontroller Peripherals , select PIO 
(Parallel I/O), and click Add.  Set the Width  to 18 and click Finish.  Refer to Figure 12. 
 
To ensure proper functionality, rename the pio_0 that was generated.  Select pio_0, right-click on it, 
select Rename, rename it to ledr, and press Enter. 

 
Figure 12.  PIO Red LED Setup 
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Add the seven-segment displays to the system.  Expand Peripherals, expand Microcontroller 
Peripherals, select PIO (Parallel I/O) , and click Add.  Set the Width  to 16 and click Finish. 
 
Repeat the previous step three more times to set up all eight of the seven-segment displays.  Refer to 
Figure 13. 
 
To ensure proper functionality, rename the pio_0-3 that were generated.  Select pio_0-3, right-click on 
them, select Rename, and rename them to seven_seg_01, seven_seg_23, seven_seg_45, and 
seven_seg_67. 

 
Figure 13.  PIO Seven-Segment Display Setup 
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Add Flash Memory 
To add the external flash memory chip to the system, add the Avalon-MM Tristate Bridge, which allows 
the Nios II processor to interface with the flash memory.  Expand Bridges and Adaptors, then expand 
Memory Mapped, select Avalon-MM Tristate Bridge , and click Add.  Leave the default settings and 
click Finish.  Refer to Figure 14. 

 
Figure 14.  Tristate Bridge Setup 

Next, add the flash memory to the system.  Expand Memories and Memory Controllers, then expand 
Flash, select Flash Memory Interface (CFI), and click Add. 
 
Set the presets to custom, address width to 22 bits, and the Data to 8 bits.  Click on the Timing tab and 
set the setup to 40, the wait to 160, and the hold to 40.  For units use ns.  Click Finish.  See Figures 15 
and 16. 
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Figure 15.  Flash Memory Setup 

 
Figure 16.  Flash Memory Timing Setup 
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Connect the flash memory to the Tristate Bridge.  Position the mouse over the Connection area of the 
Flash memory.  Click the connection circle that connects the tristate_master to s1.  Refer to Figure 17. 

 
Figure 17.  Tristate Bridge - Flash Memory Connection 
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To run the application from the flash memory instead of the On-chip memory, specify it in the cpu_0 
MegaWizard.  Select cpu_0 in the Module Name list, right-click on it, and select Edit .  Set the Reset 
Vector and the Expansion Vector to cfi_flash_0, as shown in Figure 18.  Select Finish. 

 
Figure 18.  Flash Memory Configuration 
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Assign Base Addresses 
To avoid conflicts between system components, set their base addresses.  To auto-assign the base 
addresses, select System > Auto-Assign Base Addresses.  Refer to Figure 19. 

 
Figure 19.  Auto-Assign Base Addresses 

Set Interrupt Request Priority 
Change the interrupt request (IRQ) priorities for the JTAG UART.  Click the IRQ value for the 
jtag_uart_0 component to select it.  Type 16, and press Enter to assign it a new IRQ value.  Refer to 
Figure 20. 

 
Figure 20.  JTAG UART IRQ Setup 

Generate System 
Finally, generate the system.  Click on the Generate button on the bottom of the screen.  If prompted to 
save the changes, do so.  When the system generation is complete, a message entitled Info: System 
generation was successful appears in the message box.  Upon successful system generation, close the 
SOPC Builder window. 
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Block Diagram Design in Quartus II 

Add Processor 
Now that the SOPC system is built, implement it in the block diagram file.  Open the Quartus II window.  
Right-click on the blank block diagram within the Flash_Memory.bdf tab.  Click Insert > Symbol.  A 
Symbol window opens.  In the Libraries  pane, expand Project, select NiosII_Processor, and click OK.  
Refer to Figure 21.  Click to place the symbol somewhere in the block diagram window.   

 
Figure 21.  Insert Nios II Processor 

Add VCC 
Right-click on the block diagram window again, and click Insert > Symbol.  Expand the 
c:/altera/…/libraries folder, then expand primitives, expand other, select vcc, check the box labeled 
Repeat-insert mode, and click OK.  Place vcc somewhere on the left side of the NiosII_Processor block 
near reset_n.  Place another vcc somewhere on the bottom right side of the block.  The initial placements 
of vcc are not important, as they can be moved later.  Hit Esc on the keyboard after both instances of vcc 
are placed. 

Add Output Pins 
Right-click somewhere in the block diagram window again, and click Insert > Symbol.  Expand the 
c:/altera/…/libraries folder, expand primitives, expand pin, and select output.  Check the box called 
Repeat-insert mode, and click OK.  Place three output pins below the NiosII_Processor block.  After all 
three output pins are placed, hit Esc on the keyboard. 
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Move the mouse to the blue line coming from reset_n on the block diagram.  The mouse cursor should 
change into a cross-hair shape.  When this happens, click and hold to draw a line connecting reset_n to 
the closest vcc.  Release the mouse when a small box shape appears on vcc. 
 
Click and hold vcc in order to move it.  When vcc is moved, the line connected to it follows vcc.  If the 
line moves with vcc, there is a proper connection.  If not, click and drag the mouse to connect the line 
between reset_n and vcc.  Connect all three of the output pins to the other vcc following these same 
steps. 
 
Double-click one of the output pins to open the Pin Properties window.  In the Pin name(s): section, 
rename the output pin to FL_RST_N and click OK.  Rename the other pins LCD_ON and LCD_BLON .  
Refer to Figure 22. 

 
Figure 22.  Rename Output Pins 

Right-click the NiosII_Processor block, and click Generate Pins for Symbol Ports.  Input and output 
pins are automatically generated for the rest of the Nios II system.  It is important to verify that the newly 
generated pins do not cover the vcc symbols placed earlier.  Move the vcc items to a different location if 
they are covered.  Figure 23 shows the completed setup. 
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Figure 23.  Complete Quartus II System 

Analysis and Elaboration 
The next step is Analysis and Elaboration.  Under the Processing menu, select Start > Start Analysis & 
Elaboration.  Save changes if prompted.  Upon completion of the process, a message window appears.  
Ignore any warnings, and click OK. 

Pin Assignments 
Make the pin assignments for the devices.  Under the Assignments menu, select Import Assignments… 
Click the … box to the right of the File name: section, and browse for the Pin_Assignments.csv file that 
accompanies this tutorial.  Select Open and click OK. 
 
Verify that the pins are named correctly.  Under the Assignments menu, select Pins.  In the Filter:  menu, 
choose Pins: unassigned.  Only 8 pins should appear in the list:  pins [7] and [15] from each of the pin 
groups out_port_from_the_seven_seg_XX (where XX  is 01, 23, 45, 67).  If there are more than eight 
pins listed, check the SOPC builder section of this tutorial again to ensure that all of the devices are 
named exactly as specified in this tutorial.  Close the Pins window. 

Compilation 
Compile the design.  Under Processing, select Start Compilation.  The success message in Figure 24 
appears upon completion.  Ignore the warnings that are listed, and click OK. 
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Figure 24.  Successful Compilation Window 

System Programmer 
Plug the power supply and USB-Blaster cable into the DE2 board.  Hit the red power button to turn on the 
DE2 board.  Under the Tools menu, select Programmer.  If a pop-up window appears, click OK.  In the 
Programmer window, choose Hardware Setup…  Verify that USB-Blaster[USB-0] is selected, and 
click Close.  Verify that the Mode: selected is JTAG.  Set switch SW19 on the DE2 board (next to the 
LCD) to Run.  Click Start in the programmer window.  Refer to Figure 25 for the programmer setup. 

 
Figure 25.  Programmer Window 

The window shown in Figure 26 opens.  This window confirms that the FPGA on the DE2 board 
successfully configured. 

 
Figure 26.  Successful Connection Window 
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Software Design in the Nios II IDE 

Creating a New C/C++ Application 
Next, implement a software application for the Nios II system.  Open the Nios II IDE.  Under the File 
menu, select New > Nios II C/C++ Application to open the New Project window.  In the Name: 
section, type Tutorial_Flash.  In the SOPC Builder System PTF File, browse to the location where the 
NiosII_Processor was saved (when created with SOPC Builder), and open it.  Under Select Project 
Template, select Blank Project.  Click Finish.  Refer to Figure 27. 

 
Figure 27.  New C/C++ Application Window 
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Importing Source and Header Files 
Select the Tutorial_Flash folder in the Nios II C/C++ Projects pane.  In the File menu, select Import…   
In the Import  window, select File System as shown in Figure 28, and click Next.  Browse to the folder 
containing the example files accompanying this tutorial.  Check Flash.c and header.h as shown in Figure 
29, and click Finish.  Flash.c and header.h should now appear in the Tutorial_Flash folder in the Nios II 
IDE. 

 

Figure 28.  Import File System 
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Figure 29.  Import Files 
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System Library Configuration 
Before the program can be run, it is necessary to adjust the system library properties.  Right-click on the 
Tutorial_Flash folder, and select System Library Properties.  A new window opens.  Select 
cfi_flash_0 in the Program memory (.text): drop-down menu.  Also select cfi_flash_0 for the Read-
only data memory (.rodata): drop-down menu.  Do not change any of the other default settings.  Click 
OK.  Refer to Figure 30. 

 
Figure 30.  System Library Properties 
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The Flash Programmer 
Next, load the program into flash memory.  If any changes are made in the code, save the files before 
loading them into flash.  Store the program in flash memory by selecting Tools > Flash Programmer…  
In the Flash Programmer window, select the Flash Programmer icon on the upper left side of the 
window.  Click the New launch configuration button located above the Flash Programmer icon.  Now, 
select the Program Flash button in the bottom right corner of the window.  If prompted to save changes, 
click Yes.  Click Yes in the pop-up window that appears.  Wait for the Flash Programmer to complete.  
Refer to Figure 31. 

 
Figure 31.  Flash Programmer 

Upon successful completion of the Flash Programmer, a message similar to the following displays in the 
console: 
 

Programmed 62KB +2KB in 1.3s (49.2KB/s)                     
Device contents checksummed OK 
Leaving target processor paused  
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Running the Software 
Finally, run the program.  Right-click on the Tutorial_Flash folder, and select Run As > Nios II 
Hardware.  Wait for the program to build.  Upon successful completion, a message similar to the 
following text displays in the Console pane: 

nios2-terminal: connected to hardware target using JTAG UART on cable 
nios2-terminal: "USB-Blaster [USB-0]", device 1, in stance 0 
nios2-terminal: (Use the IDE stop button or Ctrl-C to terminate) 

The DE2 board should be running the program.  If the sample code was used, the LCD should display: 

You Are AWESOME! 
LCD Works ### 

 
The seven-segment displays count in hexadecimal, and the green LEDs count in binary.  If a switch is 
switched to the up position, the red LED above the switch turns on.  If the pushbutton KEY0 is pressed, 
all of the devices count down instead of up.  If KEY1 is pressed, the devices resume counting up.  Each 
time KEY2 is pressed, the devices count incrementally faster.  Likewise, each time KEY3 is pressed, the 
devices count incrementally slower. 
 
If any changes are made to the code, save the file, and load the new code into the flash.  This is done by 
selecting File > Save All, and then by selecting Tools > Flash Programmer.  The Flash Programmer is 
already set up, so simply click the Program Flash button at the bottom of the window.  Select the C/C++ 
Projects pane, right-click on the Tutorial_Flash folder, and select Run As > Nios II Hardware.  The 
new code then runs. 

Conclusion 

This application note explains how to set up a Nios II system that uses the flash memory on Terasic 
Technologies, Inc.’s DE2 board.  The LCD controller, pushbuttons, seven-segment displays, switches, 
and red and green LEDs on the DE2 board are also used. 

Additional Information 

Getting Started with Altera’s DE2 Board.  Altera Corporation.  2008. 
DE2 User Manual.  Altera Corporation.  2005. 
Nios II Processor Reference Handbook.  Altera Corporation.  2009. 
Nios II Software Developer’s Handbook.  Altera Corporation.  2009. 
Quartus II Handbook, Volume 5: Embedded Peripherals.  Altera Corporation.  2009. 
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Disclaimer 

This document is for informational use only and is subject to change without prior notice.  Digi-Key makes no commitment to 
update or keep current the information contained herein.  Digi-Key does not guarantee or warrant that any information provided 
is accurate, complete, or correct and disclaims any and all liability associated with the use of the information contained herein.  
The use of this information and Digi-Key’s liability is subject to Digi-Key’s standard Terms & Conditions which can be found at 
www.digi-key.com by clicking on the Terms & Conditions link at the bottom of the web page. 
 
No license, whether express, implied, arising by estoppel or otherwise is granted under any intellectual property or other rights of 
Digi-Key or others. 

Trademarks 

DIGI-KEYÒ is a registered trademark of Digi-Key Corporation.  All other trademarks, service marks and product names 
contained herein are the sole property of their respective owner and their use is for informational purposes only and does not 
imply any endorsement, recommendation, sponsorship or approval by the trademark owner of the contents. 

Copyright 

Use of this document is limited to customer’s inter nal business use for the evaluation and purchase of  
products.  No permission is granted to the user to copy, print, store, distribute, transmit, display i n public or 
modify the content of this document in any way for any other purpose. 
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